
 
 
 

IMAGENEX TECHNOLOGY CORP. 
 
 

DT101Xi   
Multibeam Sonar System 

User Manual 
 
 
 

Imagenex Technology Corp. 
209-1875 Broadway Street 

Port Coquitlam, BC 
Canada V3C 4Z1 

 
Telephone: (604) 944-8248 

Fax: (604) 944-8249 
 

info@imagenex.com 
www.imagenex.com 

 
 
 
 
 
 
 
 

Number 430 - 040 

Revision Date Description 

0A September 14, 2019 For internal review 
00 September 18, 2019 For release - based on DT101Xi SIR Version 1.02.02 
   
   
   
    
   



DT101Xi Multibeam Sonar System  

Page 2 of 22 
Doc No: 430-040-00 

Table of Contents 
 
1.0 INTRODUCTION ...............................................................................................................................................5 
2.0 GETTING STARTED .........................................................................................................................................6 

2.1 Hardware Installation .....................................................................................................................................6 
2.2 Software Setup ..............................................................................................................................................6 

3.0 SOFTWARE MENUS ........................................................................................................................................9 
3.1 File .................................................................................................................................................................9 

3.1.1 File > Data from Sonar Head / Data from File… ...................................................................................9 
3.1.2 File > Record Start / Record Stop… .....................................................................................................9 
3.1.3 File > Playback File… ...........................................................................................................................9 
3.1.4 File > Use Realtime Playback Speed ...................................................................................................9 
3.1.5 File > Copy Start…/ Copy Stop .............................................................................................................9 
3.1.6 File > Convert .IGX Sonar Files to.D1P (Point) Format… ....................................................................9 
3.1.7 File > Save Screen… ............................................................................................................................9 
3.1.8 File > Exit ..............................................................................................................................................9 

3.2 Color Table ................................................................................................................................................. 10 
3.3 Setup .......................................................................................................................................................... 11 

3.3.1 Setup > IP Address… ........................................................................................................................ 11 
3.3.2 Setup > Units ..................................................................................................................................... 11 
3.3.3 Setup > Automatic Filenames (.IGX) ................................................................................................. 11 
3.3.4 Setup > Automatic Filename Type..................................................................................................... 11 
3.3.5 Setup > Set Maximum Filesize .......................................................................................................... 11 
3.3.6 Setup > Heading Input ....................................................................................................................... 12 
3.3.7 Setup > MRU Input ............................................................................................................................ 12 
3.3.8 Setup > Manual Sound Velocity… ..................................................................................................... 12 
3.3.9 Setup > Device Offsets… .................................................................................................................. 12 
3.3.10 Setup > Overlap Sonar I/O ............................................................................................................ 12 

3.4 Options ....................................................................................................................................................... 13 
3.4.1 Options > Grid .................................................................................................................................... 13 
3.4.2 Options > Sector Size ........................................................................................................................ 13 
3.4.3 Options > Beams ............................................................................................................................... 13 
3.4.4 Options > Averaging .......................................................................................................................... 13 
3.4.5 Options > Gain Equalization .............................................................................................................. 13 
3.4.6 Options > Display Track Plotter ......................................................................................................... 13 
3.4.7 Options > Clear Track Plotter ............................................................................................................ 14 
3.4.8 Options > Display Swath Coverage ................................................................................................... 14 
3.4.9 Options > Load Swath Coverage from LOG File ............................................................................... 14 
3.4.10 Options > Sidescan Window ......................................................................................................... 14 
3.4.11 Options > Echosounder Window ................................................................................................... 14 
3.4.12 Options > Intensity Window ........................................................................................................... 14 
3.4.13 Options > Diagnostics.................................................................................................................... 15 
3.4.14 Options > Sonar Info...................................................................................................................... 16 
3.4.15 Options > SIR to DT101 Packet Diagnostics ................................................................................ 17 
3.4.16 Options > Automatic Gain Control ................................................................................................. 17 

3.5 Profile Setup ............................................................................................................................................... 18 
3.5.1 Profile Setup > Profile Point Setup .................................................................................................... 18 
3.5.2 Profile Setup > Roll Correction .......................................................................................................... 20 
3.5.3 Profile Setup > Profile Tilt Angle… .................................................................................................... 21 
3.5.4 Profile Setup > Display Altitude… ...................................................................................................... 21 
3.5.5 Profile Setup > Grid Type .................................................................................................................. 21 

3.6 Data Output ................................................................................................................................................ 22 
3.7 About .......................................................................................................................................................... 22 
 

  



DT101Xi Multibeam Sonar System  

Page 3 of 22 
Doc No: 430-040-00 

Figures and Tables 
 
FIGURE 2-1 SOFTWARE USER INTERFACE ......................................................................................................................7 
TABLE 3-1 COLOUR PALETTE OPTIONS ....................................................................................................................... 10 
FIGURE 3-2 DIAGNOSTICS .......................................................................................................................................... 15 
FIGURE 3-3 SONAR INFO ............................................................................................................................................ 16 
FIGURE 3-4 PACKET DIAGNOSTICS ............................................................................................................................. 17 
FIGURE 3-5 ADVANCED FILTER SETTINGS ................................................................................................................... 19 
FIGURE 3-6 ROTATED HEAD ....................................................................................................................................... 21 
 
 
  



DT101Xi Multibeam Sonar System  

Page 4 of 22 
Doc No: 430-040-00 

 

Acronyms and Abbreviations 
 

Acronym Meaning 

MBES Multibeam Echo Sounder 
SIR Serial Interface Relay 

MRU Motion Reference Unit 
SVS Sound Velocity Sensor 

IP Internet Protocol 
PC Personal Computer 

AGC Automatic Gain Control  

 
 
 
  



DT101Xi Multibeam Sonar System  

Page 5 of 22 
Doc No: 430-040-00 

1.0 Introduction 
 
The DT101Xi is an advanced high-speed, high-resolution multibeam echosounder system (MBES) that has been 

designed to provide simple, reliable, and accurate representation of seabed bathymetry.  

 

The system consists of an underwater sonar head connected by Ethernet to an Imagenex Sensor Interface Relay 

(SIR) Box.  

 

Refer to document number 430-041-00 - Set up and Configuration of the Imagenex DT101Xi / DT102Xi Multibeam 

Echosounder. 

 

The profiling sonar has a 120° (across track) x 3° (along track) swath width and a 0.75° effective beam width and 

has an optional integrated Sound Velocity Probe (SVP) and Motion Reference Unit (MRU). All external and internal 

sensors are accurately time tagged by the SIR box to eliminate possible latency issues. 

 

The general features are: 

Frequency 240 kHz 

Minimum Range 0.5 m below transducer 

Maximum Slant Ranges 150 m 

Maximum Ping Rate 20 Hz 

Maximum Operating Depth 300 m 

Swath Width 120° x 3° 

Effective Beam Width 0.75° 

If fitted 

Motion Reference Unit (SBG Equinox 2 OEM) Pitch and Roll Accuracy:  0.04° 
Heave:  5 cm or 5% (whichever is greater) 

Sound Velocity Sensor (AML OEM) 1400 m/s to 1600 m/s +/- 0.025 m/s 
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2.0 Getting Started 

The DT101Xi was designed to be user friendly and simple to set up. It is generally recommended however to perform 

a preliminary setup before heading out into the field.  For a detailed description of recommended installation and 

setup procedures see Document Number 430-041-00 - Set up and Configuration of the Imagenex DT101Xi/ 

DT102Xi Multibeam Echosounder. 

 

2.1 Hardware Installation  

For a detailed description of hardware configuration and recommended set-up, see Document Number 430-041-00 

- Set up and Configuration of the Imagenex DT101Xi / DT102Xi Multibeam Echosounder. 

 

The minimum requirements for the user supplied PC are: 

• Intel i5 or equivalent 

• Windows™ 7 

• 8 GB RAM 

• Available discreet Gigabit Ethernet port, supported by a Realtek PCIE GBE family chipset (not an FE family 

chipset). If an external Ethernet to USB adapter is used, a high specification USB 3.0 Gigabit Ethernet 

Adapter is recommended. The TP-LINK Model UE300 appears to work well.  

• Minimum software screen resolution is 1024 x 768 

• 1 TB Hard drive 

 

2.2 Software Setup 

The sonar head needs to run with a static IP (Internet Protocol) address for both head and PC. The IP Address of 

the PC must be set to 192.168.0.X where X is any number between 3 and 9 or 11 and 254. The subnet mask is set 

to 255.255.255.0. These settings can be found in the ‘Network Connections’ item in the ‘Control Panel’. A full 

description of the process can be found in the Document Number 430-041-00 - Set up and Configuration of the 

Imagenex DT101Xi / DT102Xi Multibeam Echosounder.  

 

The IP Address of the sonar head is fixed at 192.168.0.2. 

 

DT101Xi_SIR_1.02.0X.exe (where X pertains to version number) is a Windows™ program that controls, displays 

and records data from the DT101Xi Sonar. The latest version of the program is available from the Imagenex website 

(https://imagenex.com/interior-page/software-download). 

 

The installation of the software on the PC is straightforward. It can be installed in its own directory and run by 

double clicking or you can create a shortcut from the desktop. It is not recommended that the “New Program Wizard” 

nor any other installation program be used. The program starts up in the mode that was last used (Real-time or 

Playback), or in real-time mode if it is the first time the program is run. 
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Figure 2-1 Software User Interface shows the interface with associated information. Most are self explanatory. 

Some items report software parameters whilst others allow control of the sonar.  
 

 

 
Figure 2-1 Software User Interface 

 
Controls: 
 

Range (Real-time only). Range is adjustable between 2.5 m and 150 m and sets the expected water depth. It should 

be monitored and adjusted according to the water depth at the time. 

Recommended value: 1.5 – 2 X the current water depth  

 

Gain (Real-time only): Sets the gain value of the sonar. It should be monitored and adjusted according to 

propagation conditions, water depth, ambient noise and other such factors. Adjustment should be made when the 

sonar is in High Mix mode (see Section 3.2), as this mode displays intensity and gives a better indication of the 

saturation levels of the internal receivers. If the Automatic Gain Control is set to ON, this dial has no bearing on the 

gain (see Section 3.4.16). 

Recommended value: Start at 10 dB and adjust. Optimum when sufficient returns but not saturated 

 

Display Gain: Adjust the display threshold so that sufficient data is displayed but that visual components, like the 

intensity, are not saturated. 

Recommended value: 50% during data acquisition 
 
Pause Playback:  Pauses all communication to and from the sonar head and freezes the display at the current 
point. Since data stops logging and the sonar stops the D1P data output to secondary software, this should not 
be used in real time mode while logging or acquiring data. 

Range 
Attitude and heading 

Cursor 
Position Range Gai

n 

Display 
Gain 

Pause 
Playback 

Heading 

Position 
information 

Mix (see 3.2 
Color Table 
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Roll is indicated in green if roll correction is enabled, or white if roll correction is disabled and red if out of limits  

(+ / - 15°).  

 

There are mouse driven handles that allow the minimum and maximum depth gates to be adjusted, thus defining 

an inclusion zone (in the user interface). If data falls outside this zone, it will not result in a profile point. The zones 

are visible by an upper and lower hashed area representing the minimum and maximum permitted depth. 

Adjusting these, using the mouse, updates the values set in the Profile Point Setup window (see Section 3.5.1)   
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3.0 Software Menus 

3.1 File 

3.1.1 File > Data from Sonar Head / Data from File… 

Select data source. Data can be viewed from the head in real-time, or be replayed from a previously recorded .IGX 

file. In replay mode, some of the software options become unavailable. The Range and Gain for example are not 

relevant in playback mode. IGX files are selected for playback from a normal Windows™ open dialog. 

 

3.1.2 File > Record Start / Record Stop… 

Shortcut key: Ctrl-S (Start logging) Ctrl-E (Stop logging). 

Real-time mode only 

 

Start / Stop (toggle) recording data. Stores sonar data to computer hard drive in an .IGX file format for replay and 

conversion to other formats.  Filename types and file sizes can be specified in Setup> Automatic Filenames (.IGX), 

Setup> Automatic Filename Type and Set Maximum Filesize. (See Sections 3.3.3, 3.3.4 and 3.3.5).  

It is recommended that these files be saved during all survey operations as useful data may be extracted and 

analysed from them. 

 

3.1.3 File > Playback File… 

Select a file for playback in the Open dialog. Once selected, the Playback window is automatically opened and 
allows control (via slide bars) of playback speed as well as position of the playback file being replayed. 
 
Some navigation packages allow the reading of data when the DT101Xi software is in playback mode. Once set up 
as described in Section 3.3.1, playback of a logged file appears within the navigation package as if in real-time. 
 
Once a file is opened, real-time sonar data acquisition will cease.  
 

3.1.4 File > Use Realtime Playback Speed 

Disables the speed sidebar on the Playback window so that playback speed is approximately as per data 
acquisition. Toggle on/off. 
 

3.1.5 File > Copy Start…/ Copy Stop 

Allows the recording of a portion of the .IGX file to another file. This allows the user to, for example, copy some 

interesting part of an operation from a potentially long .IGX file to one showing only the interesting section. Once 

selected, copying starts to the entered filename and the menu changes to Copy Stop… Once selected, the recording 

is terminated and the shortened section copied to the location specified. 

 

3.1.6 File > Convert .IGX Sonar Files to.D1P (Point) Format… 

Allows the conversion of one or several files from the .IGX format to the proprietary .D1P format.  
 

3.1.7 File > Save Screen… 

Copies a screen grab into a specified bitmap file for inclusion into, for example, a report. 
 

3.1.8 File > Exit 

Writes all settings to the DT101Xi _SIR.INI file that is kept in the same location as the executable file, and closes 

the program. The next time the program is started, the system will load these settings from the .INI file. 
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3.2 Colour Table 

Allows various colour combinations (background and scan) to be selected.  

 

Used to change the sonar data colour palettes for the sonar images. DT101Xi uses a colour table to represent echo 

data strength (amplitude). For example, the Normal High intensity colour table maps the echo data amplitude to 

256 colours ranging from Black (low strength level) through blue, green, orange, yellow, white, and red (highest 

strength level). 

 

The Colour Table menu offers the following options: 

 
Normal High Standard colour table used for mapping the echo data amplitude to 256 colours 

ranging from Black (low level), through Blue, Green, Orange, Yellow, White, and Red 
(highest level) 

Normal Low Same colours as Norm Hi, but uses a lower colour intensity 
Green 256 shades of green 
Grey 256 shades of Grey (White on Black) 
Reverse Grey 256 shades of Grey (Black on White) 
Brown/Yellow 256 mixed shades of brown and yellow 
Green/Blue 256 mixed shades of green and blue 
Green/Yellow 256 mixed shades of green and yellow 
Blue 256 shades of blue 

Table 3-1 Colour Palette Options 
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3.3 Setup 

3.3.1 Setup > IP Address… 

Allows for the configuration of the Internet Protocol (IP) address for both the incoming (sonar) and the outgoing 

(data to a navigation package) datagrams.  

 

The statically assigned default for the sonar IP Address in 192.168.0.2 and unless a different IP address was 

selected at the time of ordering, this should be used and is set in the Sonar IP Address textbox. 

 

Note: 192.168.0.1 is reserved for a network server and 192.168.0.10 is reserved for the SIR box and these may not 

be used. 

 

The output address is set in the Output IP address textbox. If the same machine is used to run the navigation 

package as is used to run the DT101Xi program, a loopback address may be set at 127.0.0.1. 

 

If a second computer is used to run the navigation package, this address should be set to the same IP address as 

is set in the second machine (and described in Section 2.2). Again, 192.168.0.2. and 192.168.0.10 may not be used 

as they are used by other devices (sonar head and SIR box respectively).  

 

If more computers are being used, this output address may be set to 192.168.0.255, which is a broadcast UDP 

address. Care should be taken when using this IP address as if there are additional non-DT101Xi systems on the 

192 domain, ‘broadcast’ may adversely affect communications to and from these systems. 

 

Some navigation packages allow the reading of data when the DT101Xi software is in playback mode. Once set up 

as described above, playback of a logged file (see File > Playback File…) appears within the navigation package 

as if in real-time. 

 

3.3.2 Setup > Units 

Allows for the setting of distance units to be used and only affects the displayed units with the user interface. Metres 
or feet are selected here. 
 

3.3.3 Setup > Automatic Filenames (.IGX) 

If checked, filenames for logged .IGX data (see 3.1.2 File > Record Start / Record Stop…) are assigned 

automatically. If not checked, the filename must be specified every time recording is started. Clearly, if many files 

are to be logged, it is recommended that the automatic allocation of filenames is selected. Filenames are allocated 

as either Date-number (ddmmmyyyy-nnnn.IGX) or Date-time (ddmmmyyyy-hhmmss.IGX) dependent on the 

selection described below. 

 

3.3.4 Setup > Automatic Filename Type 

Specifies the filename format, when data is recorded and Automatic Filenames selected (see Setup > Automatic 

Filenames). Two options can be selected: 

 

• Date-number (ddmmmyyyy-nnnn.IGX) 

• Date-time (ddmmmyyyy-hhmmss.IGX) 

 

3.3.5 Setup > Set Maximum Filesize 

Sets the maximum size of the file. Once this byte size has been reached, another file is created and logged to. 
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3.3.6 Setup > Heading Input 

Real-time mode only 

 

Two options are available and the user can specify the heading input source. Both NMEA $HEHDT and $GPHDT 
strings are decoded and can come into the SIR box via a GNSS (GPS) Port or via the Heading Port on the SIR box. 
See Document Number 430-041-00 - Set up and Configuration of the Imagenex DT101Xi / DT102Xi Multibeam 
Echosounder.  
 

Heading via the GNSS (GPS) Port is made available to handle dual antenna GNSS systems that calculate and 

output heading. 

 

The selection of port from which to expect heading, is specified here. 

 

3.3.7 Setup > MRU Input 

Real-time mode only 

 

Two options are available and the user can specify a motion reference source as either the integrated (SBG Ekinox-

A OEM) MRU or an external 3rd party MRU.  

 

The selection of MRU source is specified here. 

 

3.3.8 Setup > Manual Sound Velocity… 

The DT101Xi has the option of an integrated sound velocity sensor that measures the sound velocity (SV) at the 

transducer for the purposes of beam forming.  

 

This menu allows for the setting of sound velocity at the sonar head. Set the source and value of sound velocity 

here by changing the value to that observed at the surface during an SV cast and overriding the measured value if 

relevant.  

 

Note: Care should be taken when overriding the measured SV and reasons for discrepancies between the 

integrated SV sensor and cast should be investigated. 

 

The value in the textbox is read from the SV sensor, if fitted, and if a change is required, click the ‘Override real-

time sound velocity input’ checkbox and update the value.  

 

The ‘Default’ button returns the SV to 1500.0 ms-1 and unchecks the override checkbox. 

 

3.3.9 Setup > Device Offsets… 

Allows the users to enter offsets to the sonar device that could potentially be used to calculate and apply lever 

arms for induced heave. These offsets are however not applied (and included only for data format compatibility) 

to the data and heave (if MRU sensor fitted) is not corrected for these lever arms. The application of X and Y 

offsets, as well as lever arm induced heave, is typically done in the navigation package used. 

 

3.3.10 Setup > Overlap Sonar I/O 

Recommended value: Enabled 
 
Allows for the simultaneous processing and acquisition of data, thus allowing an increased ping rate. 
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3.4 Options 

3.4.1 Options > Grid 

Enables or hides the grid on the sonar display. 
 

3.4.2 Options > Sector Size 

Sets the sector size displayed on the sonar display, as well as that of any third-party software that may receive the 

sonar output message. The following sectors are selectable: 

 

30°, 60°, 90°, 100°, 110°, 120° 

 

Note that the logged .IGX file saves the full data set (regardless of Sector Size setting) and it is therefore 

recommended to log the .IGX files during survey operations. 

 

3.4.3 Options > Beams 

Sets the number of sonar beams displayed on the sonar display, as well as that of any third-party software that may 

receive the sonar output message. The higher the number of beams, the greater the angular resolution of the 

display and the greater the amount of processing required which will reduce the ping rate.  

 

The following number of beams are selectable: 

 

480, 240, 120 

 

Note that the logged .IGX file saves the full data set (regardless of Beams setting) and it is therefore recommended 

to log the .IGX files during survey operations. 

 

3.4.4 Options > Averaging 

Recommended setting: 3 for variable topography, 7 for very flat seabed  

 

Sets the number of historical returns used to derive a depth. Use this command to apply various amounts of 

averaging to the displayed image. Adjust this amount to “smooth” the image display. 

 

For example, an average of 3 will plot the average of the last 3 along-track depths received and plot the result. 

 

3.4.5 Options > Gain Equalization 

Recommended setting: On 

 

Enabling it will normalize the gain across the image and present a cleaner profile.  

 

Note that the logged .IGX file saves the full data set (regardless of the Gain Equalization setting) and it is therefore 

recommended to log the .IGX files during survey operations. 

 

3.4.6 Options > Display Track Plotter 

Opens a window that shows the X, Y (track plot) position of the vessel with the positional history since the last Clear 

(see below). Zoom in and out by left and right clicking the mouse. 
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3.4.7 Options > Clear Track Plotter 

Clears the history from the track plot. 

 

3.4.8 Options > Display Swath Coverage 

Displays the swatch coverage in the track plotter window.  

 

3.4.9 Options > Load Swath Coverage from LOG File 

If Display Track Plotter and Display Swath Coverage is enabled, a LOG file will automatically log and append to 
already logged data. This creates a log file that pertains to the entire logging session. This session log file may be 
opened and will draw completed survey area onto the track plotter window. The purpose of this is to graphically 
monitor already completed work. 
 

3.4.10 Options > Sidescan Window 

As an alternate display mode that simulates sidescan data using the separate port and starboard transducer data. 

Because it is generated from the raw sonar data, the “grazing” angle may be adjusted by adjusting the centre beam 

indicators using the left and right click of the mouse. 

 

3.4.11 Options > Echosounder Window 

Displays the seabed depth at nadir as an along-track-profile.  

 

3.4.12 Options > Intensity Window 

Displays the received intensity from the seabed, as a waterfall display. 
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3.4.13 Options > Diagnostics 

Displays various system parameters and values (as shown below) that may be useful to the user.   
 

 
Figure 3-2 Diagnostics 
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3.4.14 Options > Sonar Info 

Displays various sonar parameters and values (as shown below) that may be useful to the user.   

 

 
Figure 3-3 Sonar Info 

 
  



DT101Xi Multibeam Sonar System  

Page 17 of 22 
Doc No: 430-040-00 

3.4.15 Options > SIR to DT101 Packet Diagnostics 

Displays various packet contents (as shown below) that may be useful to the user. If no PPS is found, the display 

flashes red. 

  

 
Figure 3-4 Packet Diagnostics 

 

3.4.16 Options > Automatic Gain Control 

Toggles Automatic Gain Control (AGC) on / off. If the AGC is ON, then the gain dial in the Main window is not 
used. 
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3.5 Profile Setup 

Used to set up and control various aspects of the measured profile 

 

3.5.1 Profile Setup > Profile Point Setup 

Profile Point Display controls the way profile data is displayed on the screen.  

 

Profile Point Display 

High Mix: Image data is displayed at the normal intensity along with the generated profile points  

Med Mix: Image data is displayed at the half intensity along with the generated profile points  

Low Mix: Image data is displayed at the quarter intensity along with the generated profile points  

Points Only: Image data is not displayed. The generated profile points are displayed 

 

Large or small dots are selectable. 

 

Profile Points Detection 

 

Minimum and Maximum Depth (below sonar) may be used as a gate to permit exclusion of spurious data. 

  

The Minimum Depth setting allows the user to begin profile point detection at a certain depth below the sonar. Any 

data that is closer to the sonar than the minimum depth setting will not generate profile data points. This is very 

advantageous if undesired objects are present in the data close to the sonar.  

 

The Maximum Depth setting allows the user to end profile point detection at a certain depth below the sonar. Any 

data that is farther from the sonar than the maximum depth setting will not generate profile data points. This is very 

advantageous if undesired objects are detected beyond the range of the seabed or to eliminate second (or multiple) 

echo returns. 

 

There are mouse driven handles that allow the minimum and maximum depth gates to be adjusted on the user 

interface, thus defining an inclusion zone. If data falls outside this zone, it will not result in a profile point. The zones 

are visible by an upper and lower hashed area (diagonal lines) representing the minimum and maximum permitted 

depth. Adjusting these using the mouse updates the Minimum and Maximum Depth values set in the Profile Point 

Setup window.  

 

Note that these settings (whilst useful) are potentially dangerous with a changing seabed. An example of this would 

be to set the minimum depth to say 20 m to eliminate spurious data close to the vessel. After some time, the seabed 

then becomes shallower than 20 m and no profile points are generated for this seabed. 

 

Profile Points Filter 

There are 3 filter options: First Return, Maximum Return, and Bottom Following. Selection of one of these, deselects 

the others. If checked, Along-track Averaging will be applied to all 3 filters. 

 

First Return: The profile points will be generated on the first target whose intensity is over a fixed threshold (and 

whose range is greater than the Minimum Depth set by the user). The effect of this is that the first ensonified object 

resulting in a return, will generate profile points. 

 

Maximum Return: The profile points will be generated on the target whose intensity is the greatest for that beam 

(and whose range is greater than the Minimum Depth set by the user). The effect of this is that any objects in the 

water column which generate weaker returns than the bottom will not generate profile points. 
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Along-track Averaging: Selecting this check-box will create a profile point based on averaging a number of 

consecutive pings calculated along-track. The averaging parameter (3, 5 or 7 shots) is set as per Section 3.4.4 

Options > Averaging.  

 

The choice of which filter settings to select is dependent on the seabed type, observed or expected spurious 

contacts in the water column, etcetera, and the surveyor should experiment with different options until best results 

are obtained.  

 

Bottom Following: There are numerous filter parameters which can be changed when using the “Bottom Following” 

profile point filter. To change these parameters, select the Advanced Filter Settings button in the Profile Menu. 

 

Filter Settings. 

All Filter settings are active in real-time or during file playback, so experimentation with these settings will not affect 

the stored data in the .IGX file. The various filter settings may need to be changed depending on the bottom type 

and/or if there are targets on the bottom or in the water column (i.e. rocks, shipwrecks, fish schools, pilings, etc.). 

 

 
Figure 3-5 Advanced Filter Settings 

 

Max Points: Detects up to “Max Points” and returns the range point with the highest power (as it assumes the 

bottom echo has the highest power). A maximum of 10 points can be detected, however a setting between 2 and 5 

will generate good results. Use a setting of 1 to detect all targets in the water column. 

 

No. of Segments: Number of segments is used to help the filter work on complex bottoms (i.e. bottoms that are 

not flat) as it assumes segments are more likely to be homogenous than is the entire profile. The bottom is therefore 

divided into equal horizontal segments so the filter can act on smaller, less complex sections. Values between 3 

and 5 produce good results for typical bottom types. Bottoms with high variance are suited to a high segment 

number (up to 10) and a value of 1 could be used for a very flat bottom. 

 

No. of Depth Bins: Not used at this time 

 
The following sequence is a good starting point for experimenting with the various parameters (check the result of 

each setting before moving to the next parameter): 

 

Fill between Beams: Generates a bottom range point for beams that don’t contain valid ‘range to bottom’ values. 

The detected range points from adjacent beams are used for interpolating between the existing valid beams. 
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Main Filter: Smooths the detected range points and positions the points in the center of the returned pulse. This 

helps to generate a truer bottom profile, especially on the outer beams, where the grazing angle is such that the 

returned pulse may be scattered. 

 

Flat-bottom Filter: Reduces bottom artifacts within +/-30 degrees of nadir. This filter should be used only if 

important vertical features such as pilings or seawalls are not present within +/-30° of nadir. 

 

Remove short outliers: Short outliers are unwanted targets above the seabed and in the water column. The “% of 

range” entry sets the effective “height off bottom” setting for the filter. This setting is entered as a percentage of the 

current range scale. For example, if the current range scale is 20 m, a value of 20% would mean that all targets 

higher than 4 m above the bottom will be removed. A setting of 20% can be used for relatively flat bottoms, lower 

settings can be used for very flat bottoms. Increase to 100% to keep all water column targets.  

Note: the Profile Point Detection window (between the minimum and maximum values) setting overrides the value 

set here. If the point is not within the Profile Point Detection window, it will automatically be excluded. 

 

Display Settings 

 

Select “Show removed points” to display the removed points as enlarged green blocks (using the Norm Hi Color 

Table). Lower the “Background Level” setting to 0.1 or until the removed points are easily seen. This is a good 

diagnostic tool for evaluating the short outlier removal filter described above. 

 

3.5.2 Profile Setup > Roll Correction 

It is possible to dynamically apply roll to each scan. Roll is measured either by the integrated MRU or by an external 

MRU, depending upon the configuration. If this menu is checked, roll is applied during the beam forming process 

and data is ‘roll corrected’ in real time. This improves quality of the data as no ‘smearing’ is evident particularly at 

the outer beams during data collection. Care should be taken when processing data so as not to apply roll, as it will 

already have been applied during acquisition. 
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3.5.3 Profile Setup > Profile Tilt Angle… 

If the sonar head is at a known tilt angle (from the horizontal), this angle may be set here. This is used mainly for 

surveying structures like harbour walls, where, for example, a pre-set non-zero sonar angle enables investigation 

higher up the harbour wall (see diagram below). 

  

Figure 3-6 Rotated head 

If an integrated MRU is fitted and Roll Correction enabled, the system will apply the tilt angle plus vessel roll to the 

profile points, thus showing a flat seabed. The roll value reported in the user interface window, will have the tilt 

angle set in this menu applied, so will not show the gross roll angle (vessel roll + tilt angle) but only the vessel roll 

component. 

 

A maximum angle of +/- 30° is possible. 

 

3.5.4 Profile Setup > Display Altitude… 

Shows a window with nadir depth as text. 

 

3.5.5 Profile Setup > Grid Type 
Circular or rectangular grids are selectable in the main display window and if selected, the cursor range and 

bearing will be displayed on the user interface window. 

  

Head with tilt angle 
= 0°

Head with tilt angle 
= -30°
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3.6 Data Output 

None: A D1Z message is output on the UDP port that contains internal system strings that are used by some third 

parties. 

D1P (Point Output): Outputs a D1P message on the UDP port. A D1P message is the most common message 

used by 3rd party navigation packages and contains the point information. 

D1B (Beam Output): Outputs a D1B message on the UDP port that contains raw beam data.  

 

Clicking the Record To button allows for the simultaneous generation of either a D1P (point) or D1B (beam) format 

whilst logging or replaying sonar data. 

 
 

3.7 About  

Reports the software revision which should be quoted during any support queries. 
 


